Δευτέρα, 22 Νοεμβρίου 2010

Συγγραφή συνάρτησης

Στην Γ' τάξη ενός ημερήσιου γενικού λυκείου φοιτούν
132 μαθητές. Γράψτε συνάρτηση που δέχεται ως παραμέτρους:
* τον πραγματικό πίνακα ΥΨΗ[132], που περιέχει τα ύψη των
   μαθητών,
* τον λογικό πίνακα ΦΥΛΟ[132], που περιέχει το φύλο των
   μαθητών ( ΑΛΗΘΗΣ - αγόρι, ΨΕΥΔΗΣ - κορίτσι),
* τον πραγματικό πίνακα ΒΑΡΗ[132], που περιέχει τα βάρη
   των μαθητών
και υπολογίζει το ποσοστό (%) επί του συνόλου των αγοριών,
των μαθητών που έχουν ύψος τουλάχιστον 1.65 και ζυγίζουν
το πολύ 68 κιλά.
Παρατήρηση : Αν ο υπολογισμός του ποσοστού δεν είναι
εφικτός, η συνάρτηση επιστρέφει την τιμή -1.

Λύση

ΣΥΝΑΡΤΗΣΗ Ποσοστό(ΥΨΗ, ΦΥΛΟ, ΒΑΡΗ) : ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
      ΠΡΑΓΜΑΤΙΚΕΣ: ΥΨΗ[132], ΒΑΡΗ[132]
      ΛΟΓΙΚΕΣ: ΦΥΛΟ[132]
      ΑΚΕΡΑΙΕΣ: Λ, Φ, ΑΓΟΡΙΑ
ΑΡΧΗ
       ΑΓΟΡΙΑ <-- 0
       Φ <-- 0
       ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 132
          ΑΝ ΦΥΛΟ[Λ] = ΑΛΗΘΗΣ ΤΟΤΕ
                ΑΓΟΡΙΑ <-- ΑΓΟΡΙΑ+1
                ΑΝ (ΥΨΗ[Λ] >= 1.65) ΚΑΙ (ΒΑΡΗ[Λ] <= 68) ΤΟΤΕ
                     Φ <-- Φ+1
               ΤΕΛΟΣ_ΑΝ
          ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΑΝ ΑΓΟΡΙΑ > 0 ΤΟΤΕ
             Ποσοστό <-- 100*Φ/ΑΓΟΡΙΑ
       ΑΛΛΙΩΣ
             Ποσοστό <-- -1
       ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου