Πέμπτη, 11 Νοεμβρίου 2010

Φρουρός

Θέλετε να γεμίσετε το ντεπόζιτό σας, συνολικού όγκου 2000
λίτρων, με πετρέλαιο. Κάνετε λοιπόν μια έρευνα αγοράς
προκειμένου να εντοπίσετε το πρατήριο καυσίμων που
πουλάει το πετρέλαιο στην πιο συμφέρουσα για εσάς τιμή.
Γράψτε πρόγραμμα το οποίο:
α) διαβάζει την τιμή πώλησης ανά λίτρο του πετρελαίου σε
    διάφορα πρατήρια καυσίμων (η είσοδος δεδομένων ολοκλη-
    ρώνεται μόλις δοθεί μια μη θετική τιμή),
β) υπολογίζει και εμφανίζει:
    * τον αύξοντα αριθμό του πρατηρίου με την πιο συμφέρουσα
       τιμή πώλησης,
    * το συνολικό κόστος αγοράς του πετρελαίου.

Λύση

     ΠΡΟΓΡΑΜΜΑ ΠΕΤΡΕΛΑΙΟ
     ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Πληθ, ΑΑΜΙΝ
            ΠΡΑΓΜΑΤΙΚΕΣ: Τιμή, ΜΙΝ, Κόστος
     ΑΡΧΗ
            ΜΙΝ <-- 1000000
            Πληθ <-- 0
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                   ΔΙΑΒΑΣΕ Τιμή
                   ΑΝ Τιμή > 0 ΤΟΤΕ
                         Πληθ <-- Πληθ+1
                         ΑΝ Τιμή < ΜΙΝ ΤΟΤΕ
                               ΜΙΝ <-- Τιμή
                               ΑΑΜΙΝ <-- Πληθ
                         ΤΕΛΟΣ_ΑΝ
                   ΤΕΛΟΣ_ΑΝ
            ΜΕΧΡΙΣ_ΟΤΟΥ Τιμή <= 0
            ΑΝ Πληθ > 0 ΤΟΤΕ
                   Κόστος <-- 2000*ΜΙΝ
                   ΓΡΑΨΕ ΑΑΜΙΝ, Κόστος
            ΑΛΛΙΩΣ
                   ΓΡΑΨΕ 'Δε δόθηκαν δεδομένα'
            ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου