Σάββατο, 13 Νοεμβρίου 2010

Άσκηση : Απάντηση σε ερώτηση+αναγωγή στη μονάδα+πορτοφόλι

Γράψτε αλγόριθμο που:
α) διαβάζει τις τιμές πώλησης και το πλήθος σε κόλλες
    κάποιων τετραδίων (η είσοδος δεδομένων ολοκληρώνεται
    μόλις δοθεί η απάντηση 'Ο' ή 'ο' στην υποβαλλόμενη προς
    το χρήστη ερώτηση 'Υπάρχει άλλο τετράδιο;'),
β) υπολογίζει και εμφανίζει:
    * πόσα τετράδια εξετάστηκαν συνολικά,
    * τον αύξοντα αριθμό του πιο συμφέροντος τετραδίου,
    * πόσα τέτοια τετράδια μπορείτε να προμηθευτείτε με
       27 ευρώ.
Παρατηρήσεις
Ι. Κανένα τετράδιο δεν είχε τιμή πώλησης μεγαλύτερη από
    7 ευρώ.
ΙΙ. Η πιο συμφέρουσα επιλογή είναι μοναδική.
ΙΙΙ. Δεν απαιτείται έλεγχος της εγκυρότητας των εισερχόμενων
      δεδομένων.

Λύση

     Αλγόριθμος Τετράδια
     ΜΙΝ <-- 8
     Πληθ <-- 0
     Αρχή_επανάληψης
           Διάβασε Τιμή, Κόλλες
           Πληθ <-- Πληθ+1
           ΤιμΚολ <-- Τιμή/Κόλλες
           Αν ΤιμΚολ < ΜΙΝ τότε
                ΜΙΝ <-- ΤιμΚολ
                ΑΑΜΙΝ <-- Πληθ
                ΣυμφΤιμ <-- Τιμή
           Τέλος_αν
           Εμφάνισε 'Υπάρχει άλλο τετράδιο;'
           Διάβασε Απ
     Μέχρις_ότου (Απ = 'Ο') Ή (Απ = 'ο')
     Εμφάνισε Πληθ, ΑΑΜΙΝ
     Ποσό <-- 27
     Αγ <-- 0
     Όσο Ποσό >= ΣυμφΤιμ επανάλαβε
           Ποσό <-- Ποσό-ΣυμφΤιμ
           Αγ <-- Αγ+1
     Τέλος_επανάληψης
     Εμφάνισε Αγ
     Τέλος Τετράδια
  

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου