Πέμπτη, 18 Νοεμβρίου 2010

Άσκηση : Απάντηση σε ερώτηση

Γράψτε αλγόριθμο που διαβάζει τις ημερομηνίες γέννησης
(μέρα, μήνας, έτος) κάποιων ανθρώπων (η είσοδος δεδομένων
ολοκληρώνεται μόλις δοθεί η απάντηση 'ναι' στην υποβαλλόμενη
προς το χρήστη ερώτηση 'Ολοκληρώθηκε η είσοδος;'),
υπολογίζει και εμφανίζει:
α) πόσοι έχουν γεννηθεί άνοιξη,
β) το ποσοστό (%) αυτών που έχουν γεννηθεί καλοκαίρι,
γ) το μέσο όρο ηλικίας αυτών που έχουν γεννηθεί πριν από
    το 1965,
δ) πόσοι γεννήθηκαν μέσα στο πρώτο δεκαπενθήμερο κάποιου
    μήνα.
Παρατήρηση : Όλες οι τιμές εισόδου είναι ακεραίου τύπου και δεν
απαιτείται κανένας έλεγχος της εγκυρότητάς τους.

Λύση

       Αλγόριθμος Άνθρωποι
       Ανοιξη <-- 0
       Καλοκ <-- 0
       ΠρινΑπο <-- 0
       σ <-- 0
       Πληθ <-- 0
       Δεκ <-- 0
       Αρχή_επανάληψης
            Διάβασε Μέρα, Μήνας, Έτος
            Πληθ <-- Πληθ+1
            Αν (Μήνας >= 3) ΚΑΙ (Μήνας <= 5) τότε
                 Άνοιξη <-- Άνοιξη+1
            Τέλος_αν
            Αν (Μήνας >= 6) ΚΑΙ (Μήνας <= 8) τότε
                 Καλοκ <-- Καλοκ+1
            Τέλος_αν
            Αν Έτος < 1965 τότε
                 ΠρινΑπο <-- ΠρινΑπο+1
                 σ <-- σ+(2010-Έτος)
            Τέλος_αν
            Αν (Μέρα >= 1) ΚΑΙ (Μέρα <= 15) τότε
                 Δεκ <-- Δεκ+1
            Τέλος_αν
            Εμφάνισε 'Ολοκληρώθηκε η είσοδος;'
            Διάβασε Απ
       Μέχρις_ότου Απ = 'ναι'
       ΠΟΣ <-- 100*Καλοκ/Πληθ
       Εμφάνισε Άνοιξη, ΠΟΣ, Δεκ
       Αν ΠρινΑπο > 0 τότε
            ΜΟ <-- σ/ΠρινΑπο
            Εμφάνισε ΜΟ
       αλλιώς 
            Εμφάνισε 'Δεν υπάρχει κανένας γεννηθείς πριν το 65'
       Τέλος_αν
       Τέλος Άνθρωποι

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου