Πέμπτη, 18 Νοεμβρίου 2010

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παραμέτρους δύο
ακέραιες τιμές Α, Β και επιλύει την εξίσωση
       Α |Χ| = Β

Λύση

       ΔΙΑΔΙΚΑΣΙΑ ΕΞΙΣΩΣΗ(Α, Β)
       ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: Α, Β,
             ΠΡΑΓΜΑΤΙΚΕΣ : Υ, Χ1, Χ2
       ΑΡΧΗ
             ΑΝ Α < > 0 ΤΟΤΕ
                  Υ <-- Β/Α
                   ΑΝ Υ > 0 ΤΟΤΕ
                         Χ1 <-- Υ
                         Χ2 <-- -Υ
                         ΓΡΑΨΕ Χ1, Χ2
                   ΑΛΛΙΩΣ_ΑΝ Υ = 0 ΤΟΤΕ
                         ΓΡΑΨΕ 'Χ = 0'
                   ΑΛΛΙΩΣ
                         ΓΡΑΨΕ 'ΑΔΥΝΑΤΗ'
                   ΤΕΛΟΣ_ΑΝ
             ΑΛΛΙΩΣ
                   ΑΝ Β = 0 ΤΟΤΕ
                         ΓΡΑΨΕ 'ΑΠΕΙΡΕΣ ΛΥΣΕΙΣ'
                   ΑΛΛΙΩΣ
                         ΓΡΑΨΕ 'ΑΔΥΝΑΤΗ'
                   ΤΕΛΟΣ_ΑΝ
             ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου