Τετάρτη, 3 Νοεμβρίου 2010

Λογικό διάγραμμα (Όσο+Αν..τότε..αλλιώς)

Κατασκευάστε το λογικό διάγραμμα του παρακάτω
αλγόριθμου
      Αλγόριθμος ΑΣΚ
      Διάβασε Ν
      Α <-- 0
      Κ <-- 1
      Όσο Κ <= 10 επανάλαβε
            Αν Κ >= 5 τότε
                  Α <-- Α+Κ*Ν
            αλλιώς
                  Α <-- Α-Κ*Ν
            Τέλος_αν
            Κ <-- Κ+1
      Τέλος_επανάληψης
      Εμφάνισε Α
      Τέλος ΑΣΚ
    
Λύση



Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου