Τετάρτη, 25 Απριλίου 2012

Μετατροπή

Μετατρέψτε το παρακάτω σύνολο εντολών σε ισοδύναμο, χρησιμοποιώντας μόνο την εντολή Όσο..επανάλαβε
        Αρχή_επανάληψης
             Διάβασε χ
             σ <-- χ
             Διάβασε μ
             Αρχή_επανάληψης
                  σ <-- σ+μ
                  Διάβασε μ
             Μέχρις_ότου μ <= 0
        Μέχρις_ότου σ > 1000

Απάντηση

         σ <-- 999
         Όσο σ <= 1000 επανάλαβε
              Διάβασε χ
              σ <-- χ
              Διάβασε μ
              σ <-- σ+μ
              Διάβασε μ
              Όσο μ > 0 επανάλαβε
                  σ <-- σ+μ
                  Διάβασε μ
              Τέλος_επανάληψης
         Τέλος_επανάληψης

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου