Πέμπτη, 19 Απριλίου 2012

Συγγραφή συνάρτησης

Γράψτε συνάρτηση η οποία δέχεται ως παράμετρο έναν ακέραιο
πίνακα Α[12, 12] και υπολογίζει το αποτέλεσμα της παράστασης
(Χ+Υ)*Ζ, όπου:
    Χ : το άθροισμα των στοιχείων της πρώτης κυρίας διαγωνίου,
    Υ : το πλήθος των μηδενικών στοιχείων της δεύτερης κυρίας
          διαγωνίου,
    Ζ : το μεγαλύτερο στοιχείο του πίνακα

Λύση


      ΣΥΝΑΡΤΗΣΗ ΥΠΟΛ(Α) : ΑΚΕΡΑΙΑ
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Α[12, 12], Κ, Λ, Χ, Υ, ΜΕΓ
      ΑΡΧΗ
            Χ <-- 0
            Υ <-- 0
            ΜΕΓ <-- Α[1, 1]
            ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
                ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 12
                      ΑΝ Κ = Λ ΤΟΤΕ
                            Χ <-- Χ+Α[Κ, Λ]
                      ΤΕΛΟΣ_ΑΝ
                      ΑΝ Κ+Λ = 13 ΤΟΤΕ
                           ΑΝ Α[Κ, Λ] = 0 ΤΟΤΕ
                                Υ <-- Υ+1
                           ΤΕΛΟΣ_ΑΝ
                      ΤΕΛΟΣ_ΑΝ
                      ΑΝ Α[Κ, Λ] > ΜΕΓ ΤΟΤΕ
                            ΜΕΓ <-- Α[Κ, Λ]
                      ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΥΠΟΛ <-- (Χ+Υ)*Ζ
      ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου