Τρίτη, 3 Απριλίου 2012

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο ο οποίος:
α) διαβάζει πόσα αγόρια και πόσα κορίτσια έχει καθεμιά από
    120 οικογένειες ενός χωριού,
β) υπολογίζει και εμφανίζει:
    * το ποσοστό (%) των οικογενειών που έχουν μόνο κορίτσια,
    * το μέσο όρο πλήθους αγοριών για κάθε οικογένεια που έχει
      τουλάχιστον ένα αγόρι.
Παρατηρησεις
1. Δεν απαιτείται κανένας έλεγχος εγκυρότητας των  εισερχόμενων
    δεδομένων.
2. Θεωρείστε ότι τα δεδομένα που δίνονται είναι τέτοια ώστε τα
   ζητούμενα του ερωτήματος β) να μπορούν να υπολογιστούν.

Λύση

      Αλγόριθμος Οικογ
      Μονο <-- 0
      σ <-- 0
      ΟικΑγ <-- 0
      Για κ από 1 μέχρι 120
          Διάβασε Αγόρια, Κορίτσια
          Αν  Αγόρια > 0 τότε 
               σ <-- σ+Αγόρια
               ΟικΑγ <-- ΟικΑγ+1
          αλλιώς
                Αν Κορίτσια > 0 τότε
                    Μονο <-- Μονο+1
                Τέλος_αν
          Τέλος_αν
      Τέλος_επανάληψης
      ΜΟΑγ <-- σ/ΟικΑγ
      ΠοσΜονο <-- 100*Μονο/120
      Εμφάνισε
      Τέλος Οικογ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου