Τρίτη, 10 Απριλίου 2012

Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών μόνο με
Αν..τότε και Μέχρις_ότου
        Για κ από 11 μέχρι Χ
             Εμφάνισε κ
             Για λ από Υ μέχρι 2 με_βήμα -1
                  Εμφάνισε λ
                  Για μ από 4 μέχρι Ζ με_βήμα 3
                       Εμφάνισε κ+λ+μ
                  Τέλος_επανάληψης
             Τέλος_επανάληψης
        Τέλος_επανάληψης


Λύση


       Αν Χ >= 11 τότε
           κ <-- 11
           Αρχή_επανάληψης
                Εμφάνισε κ
                Αν Υ >= 2 τότε
                     λ <-- Υ
                     Αρχή_επανάληψης
                           Εμφάνισε λ
                           Αν Ζ >= 4 τότε
                                μ <-- 4
                                Αρχή_επανάληψης
                                     Εμφάνισε κ+λ+μ
                                     μ <-- μ+3
                                Μέχρις_ότου μ > Ζ
                           Τέλος_αν
                           λ <-- λ-1
                     Μέχρις_ότου λ < 2
                Τέλος_αν
                κ <-- κ+1
           Μέχρις_ότου κ > Χ
       Τέλος_αν

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου