Πέμπτη, 29 Μαρτίου 2012

Επεξεργασία δοσμένου πλήθους τιμών

Γράψτε αλγόριθμο που διαβάζει 50 αριθμητικές τιμές, υπολογίζει
και εμφανίζει το μέσο όρο των τιμών που ήταν ακέραιες (αν
υπάρχουν).

Λύση


     Αλγόριθμος Ασκ
     σ <-- 0
     Ακερ <-- 0
     Για κ από 1 μέχρι 50
         Διάβασε Χ
         Αν Α_Μ(Χ) = Χ τότε
              σ <-- σ+Χ
              Ακερ <-- Ακερ+1
         Τέλος_αν
     Τέλος_επανάληψης
     Αν Ακερ > 0 τότε
           ΜΟ <-- σ/Ακερ
           Εμφάνισε ΜΟ
     αλλιώς
           Εμφάνισε 'Δεν υπάρχει κανένας ακέραιος!'
     Τέλος_αν
     Τέλος Ασκ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου