Πέμπτη, 1 Μαρτίου 2012

Υπολογισμός ΜΚΔ

Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
α) διαβάζει δύο θετικούς ακέραιους Α, Β τέτοιους ώστε
    Α > Β (να διασφαλίζεται η εγκυρότητα των εισερχόμενων
    δεδομένων),
β) να υπολογίζει και να εμφανίζει το μέγιστο κοινό
    διαιρέτη (ΜΚΔ) των Α, Β.

Λύση

     ΠΡΟΓΡΑΜΜΑ ΜΕΓ_ΚΟΙΝ_ΔΙΑΙΡ
     ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Α, Β, ΥΠΟΛ, ΜΚΔ
     ΑΡΧΗ
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                   ΔΙΑΒΑΣΕ Α, Β
            ΜΕΧΡΙΣ_ΟΤΟΥ (Α > 0) ΚΑΙ (Β > 0) ΚΑΙ (Α > Β)
            ΥΠΟΛ <-- Β
            ΟΣΟ ΥΠΟΛ < > 0 ΕΠΑΝΑΛΑΒΕ
                   ΥΠΟΛ <-- Α MOD B
                   A <-- B
                   B <-- ΥΠΟΛ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΜΚΔ <-- Α
            ΓΡΑΨΕ 'ΜΚΔ = ', ΜΚΔ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου