Πέμπτη, 15 Μαρτίου 2012

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση η οποία δέχεται ως παράμετρο ένα
ακέραιο πίνακα Α[12, 12] και υπολογίζει το μέσο όρο
των θετικών στοιχείων του (αν δεν υπάρχουν καθόλου
θετικά στοιχεία στοιχεία επιστρέφει την τιμή -1).

Λύση

     ΣΥΝΑΡΤΗΣΗ ΜΟΘ(Α) : ΑΚΕΡΑΙΑ
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α[12, 12], Κ, Λ, Σ, ΘΕΤ
     ΑΡΧΗ
           Σ <-- 0
           ΘΕΤ <-- 0
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
               ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 12
                      ΑΝ Α[Κ, Λ] > 0 ΤΟΤΕ
                            ΘΕΤ <-- ΘΕΤ+1
                            Σ <-- Σ+ΘΕΤ
                      ΤΕΛΟΣ_ΑΝ
               ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΑΝ ΘΕΤ > 0 ΤΟΤΕ
                ΜΟΑ <-- Σ/ΘΕΤ
           ΑΛΛΙΩΣ
                ΜΟΑ <-- -1
           ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ  

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου