Πέμπτη, 22 Μαρτίου 2012

Ποιο είναι το περιεχόμενο του πίνακα

Ποιο θα είναι το περιεχόμενο του πίνακα Α[3, 4] μετά
την εκτέλεση των παρακάτω εντολών;
Για κ από 1 μέχρι 3
       Για λ από 1 μέχρι 4
              Α[κ, λ] <-- κ + λ mod 5
       Τέλος_επανάληψης
Τέλος_επανάληψης

Απάντηση
Ο κανόνας με τον οποίο γεμίζει ο πίνακας είναι απλός:
κάθε στοιχείο του παίρνει ως τιμή το αποτέλεσμα που
προκύπτει αν αθροίσουμε τη γραμμή στην οποία ανήκει
με τη στήλη στην οποία ανήκει (αφού λ mod 5 = λ, αν
λ <=4). Κατά συνέπεια ο πίνακας έχει το περιεχόμενο:
      2     3      4       5
      3     4      5       6
      4     5      6       7

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου