Κυριακή, 11 Μαρτίου 2012

Προσδιορίστε το περιεχόμενο του πίνακα

Ποιο είναι το περιεχόμενο του πίνακα Α[2, 3] μετά την
εκτέλεση των παρακάτω εντολών;
      Για κ από 1 μέχρι 2
           Για λ από 1 μέχρι 3
                Αν κ >= λ τότε
                       Α[κ, λ] <-- κ div λ
                αλλιώς
                       Α[κ, λ] <-- κ*λ
                Τέλος_αν
           Τέλος_επανάληψης
      Τέλος_επανάληψης

Λύση

     Παρατηρούμε ότι όταν η γραμμή στην οποία ανήκει το στοιχείο
     είναι μεγαλύτερη ή ίση από τη στήλη, εκχωρείται ως περιεχόμενο
     το πηλίκο της διαίρεσης των δύο συντεταγμένων. Σε αντίθετη
     περίπτωση το γινόμενό τους. Κατά συνέπεια:
          Α[1, 1] = 1 div 2 = 0
          A[1, 2] = 1*2 = 2
          A[1, 3] = 1*3 = 3
          A[2, 1] = 2 div 1 = 2
          A[2, 2] = 2 div 2 = 1
          A[2, 3] = 2*3 = 6
     To περιεχόμενο του πίνακα λοιπόν είναι:
              0       2       3
              2       1       6
  
    

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου