Κυριακή, 11 Μαρτίου 2012

Συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία γεμίζει τον ακέραιο πίνακα
Α[10] με τις τιμές Χ και Υ (εναλλάξ).

Λύση

      ΔΙΑΔΙΚΑΣΙΑ ΓΕΜ(Α, Χ, Υ)
      ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ : Α[10], Χ, Υ
      ΑΡΧΗ
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 9 ΜΕ_ΒΗΜΑ 2
                 Α[Κ] <-- Χ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΙΑ Κ ΑΠΟ 2 ΜΕΧΡΙ 10 ΜΕ_ΒΗΜΑ 2
                 Α[Κ] <-- Υ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου