Πέμπτη, 15 Μαρτίου 2012

Συγγραφή διαδικασίας

Γράψτε διαδικασία που γεμίζει τον ακέραιο πίνακα Α[12, 3, 9]
έτσι ώστε σε κάθε στοιχείο του να εκχωρείται ως τιμή το
γινόμενο των τριών συντεταγμένων του.

Λύση

       ΔΙΑΔΙΚΑΣΙΑ ΓΕΜ(Α)
       ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: Α[12, 3, 9], Κ, Λ, Μ
       ΑΡΧΗ
             ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
                  ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 3
                       ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 9
                              Α[Κ, Λ, Μ] <-- Κ*Λ*Μ
                       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου