Τετάρτη, 6 Απριλίου 2011

Ποιά είναι η τελική τιμή της μεταβλητής

θεωρήστε ένα πίνακα Α[24] που περιέχει 12 θετικές και 12
αρνητικές τιμές. Ποιά είναι η τελική τιμή της μεταβλητής
ζ μετά την εκτέλεση των παρακάτω εντολών;
    ζ <-- 0
    χ <-- 1
    Για κ από 4 μέχρι 9 με_βήμα 3
         Για λ από 5 μέχρι 8
              Για μ από 12 μέχρι 10 με_βήμα -1
                   Αν Α[χ] > 0 τότε
                        ζ <-- ζ+1
                   αλλιώς
                        ζ <-- ζ+2
                   Τέλος_αν
                   χ <-- χ+1
              Τέλος_επανάληψης
         Τέλος_επανάληψης
    Τέλος_επανάληψης


Λύση


     Η πρώτη Για εκτελείται 2 φορές, η δεύτερη Για 4 φορές,
     και η τρίτη Για 3 φορές.  Αφού το συνολικό πλήθος των
     επαναλήψεων είναι 2 Χ 4 Χ 3 = 24, η Αν..τότε..αλλιώς
     ελέγχει όλα τα στοιχεία του πίνακα και τις μισές φορές
     αυξάνει το ζ κατά 1 και τις άλλες μισές κατά 2. Κατά
     συνέπεια έχουμε ζ = 0+12*1+12*2 = 36

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου