Τετάρτη, 6 Απριλίου 2011

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση η οποία δέχεται ως παραμέτρους τα
άκρα Χ, Υ ενός ακέραιου διαστήματος και υπολογίζει
πόσες από τις τιμές του παραπάνω διαστήματος είναι
διαιρέτες του Χ+Υ.

Λύση

      ΣΥΝΑΡΤΗΣΗ ΠΟΣΕΣ(Χ, Υ) : ΑΚΕΡΑΙΑ
      ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: Χ, Υ, Λ, ΑΠΟΤ, ΠΛΗΘ
      ΑΡΧΗ
             ΑΠΟΤ <-- Χ+Υ
             ΠΛΗΘ <-- 0
             ΓΙΑ Λ ΑΠΟ Χ ΜΕΧΡΙ Υ
                  ΑΝ ΑΠΟΤ MOD Λ = 0 ΤΟΤΕ
                        ΠΛΗΘ <-- ΠΛΗΘ+1
                  ΤΕΛΟΣ_ΑΝ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΠΟΣΕΣ <-- ΠΛΗΘ
      ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου