Δευτέρα, 25 Απριλίου 2011

Άσκηση : επιλεκτική ταξινόμηση

Θεωρείστε ένα πίνακα Α[50] που περιέχει εναλλάξ άρτιες και
περιττές τιμές (στην πρώτη θέση του πίνακα περιέχεται
άρτιος ακέραιος). Γράψτε αλγόριθμο που ταξινομεί, μόνο
τις άρτιες τιμές, κατά φθίνουσα σειρά.

Λύση

      Αλγόριθμος Ταξ
      Δεδομένα // Α //
      χ <-- 1
      Για κ από 1 μέχρι 49 με_βήμα 2
           Β[χ] <-- Α[κ]
           χ <-- χ+1
      Τέλος_επανάληψης
      Για κ από 2 μέχρι 25
           Για λ από 25 μέχρι κ με_βήμα -1
                 Αν Β[λ-1] < Β[λ] τότε
                      Βοηθ <-- Β[λ-1]
                      Β[λ-1] <-- Β[λ]
                      Β[λ] <-- Βοηθ
                 Τέλος_αν
           Τέλος_επανάληψης
      Τέλος_επανάληψης
      χ <-- 1
      Για κ από μέχρι 49 με_βήμα 2
           Α[κ] <-- Β[χ]
           χ <-- χ+1
      Τέλος_επανάληψης  
      Αποτελέσματα // Α //
      Τέλος Ταξ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου