Σάββατο, 9 Απριλίου 2011

Απλοποίηση

Απλοποιήστε το παρακάτω σύνολο εντολών και εξαφανίσετε
τους περιττούς ελέγχους

      Διάβασε μ, ν
      Αν (μ < 0) Ή (μ > 0) τότε
           ζ <-- μ*ν
      αλλιώς
           ζ <-- μ*(ν+1000)
      Τέλος_αν
      λ <-- Α_Τ(ζ) mod (A_T(ζ)+1)
         
Λύση

      Διάβασε μ, ν
      Αν μ < > 0 τότε
           ζ <-- μ*ν
      αλλιώς    ! μ = 0
           ζ <-- 0
      Τέλος_αν
      λ <-- Α_Τ(ζ)
  

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου