Τρίτη, 19 Απριλίου 2011

Άσκηση : Απάντηση σε ερώτηση

Γράψτε αλγόριθμο που διαβάζει τους τίτλους κάποιων τηλεο-
πτικών ειδησιογραφικών εκπομπών, το αντικείμενο τους,
τα ονοματεπώνυμα των παρουσιαστών τους, το κόστος
παραγωγής τους και το τηλεοπτικό κανάλι στο οποίο "παίζουν"
(η είσοδος δεδομένων ολοκληρώνεται μόλις δοθεί η απάντηση
'Ν' στην υποβαλλόμενη προς το χρήστη ερώτηση 'Ολοκληρώ-
θηκε η είσοδος;'), υπολογίζει και εμφανίζει:
α) τον τίτλο της εκπομπής που έχει το μεγαλύτερο κόστος
    παραγωγής, το αντικείμενό της, το ονοματεπώνυμο του
    παρουσιαστή της και το τηλεοπτικό κανάλι στο οποίο
    "παίζει",
β) πόσες από τις εκπομπές έχουν αντικείμενο τους την
    ΟΙΚΟΝΟΜΙΑ,
γ) το ποσοστό (%) των εκπομπών που "παίζουν" στο
    κανάλι  ΑΝΕΠ_CHANNEL,
δ) το μέσο κόστος παραγωγής ανά εκπομπή.

Λύση

      Αλγόριθμος Εκπομπές
      Μεγ <-- -1
      Οικ <-- 0
      Ανεπ <-- 0
      Πληθ <-- 0
      σ <-- 0
      Αρχή_επανάληψης
           Διάβασε Τίτλος, Αντικ, Ονεπ, Κοστ, Καν
           Αν Κοστ > Μεγ τότε
                Μεγ <-- Κοστ
                ΜεγΤιτλ <-- Τίτλος
                ΜεγΑντ <-- Αντικ
                ΜεγΟν <-- Ονεπ
                ΜεγΚαν <-- Καν
           Τέλος_αν
           Αν Αντικ = 'ΟΙΚΟΝΟΜΙΑ' τότε
                 Οικ <-- Οικ+1
           Τέλος_αν
           Αν Καν = 'ΑΝΕΠ_CHANNEL' τότε
                 Ανεπ <-- Ανεπ+1
           Τέλος_αν
           Πληθ <-- Πληθ+1
           σ <-- σ+Κοστ
           Εμφάνισε 'Ολοκληρώθηκε η είσοδος;'
           Διάβασε Απ
      Μέχρις_ότου Απ = 'Ν'
      ΜΟ <-- σ/Πληθ
      Εμφάνισε ΜεγΤιτλ, ΜεγΑντ, ΜεγΟν, ΜεγΚαν
      ΠΟΣ <-- 100*Ανεπ/Πληθ
      Εμφάνισε Οικ
      Εμφάνισε ΠΟΣ
      Εμφάνισε ΜΟ
      Τέλος Εκπομπές

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου