Δευτέρα, 4 Απριλίου 2011

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία δέχεται ως παραμέτρους:
* την τρέχουσα ημερομηνία (μέρα, αύξοντα αριθμό μήνα,
   έτος),
* το πλήθος των ημερών του τρέχοντος μήνα
και υπολογίζει την ημετρομηνία της επόμενης μέρας.

Λύση

    ΔΙΑΔΙΚΑΣΙΑ Ημερ(Μ, Μην, Χρ, Πληθ, ΕπΜ, ΕπΜην, ΕπΧρ)
    ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Μ, Μην, Χρ, Πληθ, ΕπΜ, ΕπΜην, ΕπΧρ
    ΑΡΧΗ
          ΑΝ Μ < Πληθ ΤΟΤΕ
                ΕπΜ <-- Μ+1
                ΕπΜην <-- Μην
                ΕπΧρ <-- Χρ
          ΑΛΛΙΩΣ
                ΕπΜ <-- 1
                ΑΝ Μην < 12 ΤΟΤΕ
                     ΕπΜην <-- Μην+1
                     ΕπΧρ <-- Χρ
                ΑΛΛΙΩΣ
                     ΕπΜην <-- 1
                     ΕπΧρ <-- Χρ+1
                ΤΕΛΟΣ_ΑΝ
          ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου