Πέμπτη, 21 Απριλίου 2011

Άσκηση: συγγραφή συνάρτησης

Γράψτε συνάρτηση που υπολογίζει πόσοι συνδιασμοί τιμών
των ακέραιων μεταβλητών Χ, Υ, Ζ στο ακέραιο διάστημα
[Α, Β], κάνουν το αποτέλεσμα της παράστασης  Χ+Υ+Ζ
άρτιο.

Λύση

       ΣΥΝΑΡΤΗΣΗ ΣΥΝΔ(Α, Β) : ΑΚΕΡΑΙΑ
       ΜΕΤΑΒΛΗΤΕΣ
              ΑΚΕΡΑΙΕΣ: Α, Β, Χ, Υ, Ζ, ΠΛΗΘ
       ΑΡΧΗ
              ΠΛΗΘ <-- 0
              ΓΙΑ Χ ΑΠΟ Α ΜΕΧΡΙ Β
                   ΓΙΑ Υ ΑΠΟ Α ΜΕΧΡΙ Β
                         ΓΙΑ Ζ ΑΠΟ Α ΜΕΧΡΙ Β
                               ΑΝ (Χ+Υ+Ζ) MOD 2 = 0 TOTE
                                     ΠΛΗΘ <-- ΠΛΗΘ+1
                               ΤΕΛΟΣ_ΑΝ
                         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΣΥΝΔ <-- ΠΛΗΘ
       ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου