Τρίτη, 12 Απριλίου 2011

άσκηση : απάντηση σε ερώτηση

Γράψτε αλγόριθμο που διαβάζει τις διευθύνσεις (πόλη, οδός,
νούμερο) κάποιων πολιτών (η είσοδος δεδομένων ολοκληρώ-
νεται μόλις δοθεί η απάντηση ΌΧΙ' στην υποβαλλόμενη προς
το χρήστη ερώτηση 'Υπάρχει άλλη διεύθυνση;'), υπολογίζει
και εμφανίζει:
α) το πλήθος των διευθύνσεων που επεξεργαστήκατε,
β) πόσες από τις διευθύνσεις αυτές βρίσκονται στην οδό
    Γεννηματά στο Ηράκλειο,
γ) το ποσοστό (%) των διευθύνσεων στις οποίες το νούμερο
    είναι άρτιος αριθμός.


Λύση

       Αλγόριθμος Κάτοικοι
       Πληθ <-- 0
       ΓενΗρακ <-- 0
       Αρτ <-- 0
       Αρχή_επανάληψης
             Διάβασε Πόλη, Οδός, Νο
             Πληθ <-- Πληθ+1
             Αν (Πόλη = 'Ηράκλειο') ΚΑΙ (Οδός = 'Γεννηματά')
             τότε
                  ΓενΗρακ <-- ΓενΗρακ+1
             Τέλος_αν
             Αν Νο mod 2 = 0 τότε
                  Αρτ <-- Αρτ+1
             Τέλος_αν
             Εμφάνισε 'Υπάρχει άλλη διεύθυνση;'
             Διάβασε Απ
       Μέχρις_ότου Απ = 'ΟΧΙ'
       ΠΟΣ <-- 100*Αρτ/Πληθ
       Εμφάνισε Πληθ, ΓενΗρακ, ΠΟΣ
       Τέλος Κάτοικοι

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου