Τρίτη, 26 Απριλίου 2011

Άσκηση : επεξεργασία στοιχείων μονοδιάστατου πίνακα

Δίνεται πίνακας Α[80] που περιέχει 40 άσσους και 40
μηδενικά. Γράψτε αλγόριθμο που αναδιοργανώνει το
περιεχόμενο του Α κατά τέτοιο τρόπο ώστε τα μηδενικά
να καταλαμβάνουν τις τελευταίες θέσεις του πίνακα.

Λύση

    Αλγόριθμος ΑΣΚ
    Δεδομένα // Α //
    λ <-- 0
    Για κ από 1 μέχρι 80
        Αν Α[κ] < >  0 τότε
             λ <-- λ+1
             Β[λ] <-- Α[κ]
    Τέλος_επανάληψης
    Για κ από 1 μέχρι 40
          Α[κ] <-- Β[κ]
          Α[κ+40] <-- 0
    Τέλος_επανάληψης
    Αποτελέσματα // Α //
    Τέλος ΑΣΚ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου