Παρασκευή, 1 Απριλίου 2011

Άσκηση : Αναζήτηση (μονοδιάστατος+δισδιάστατος πίνακας)

Γράψτε αλγόριθμο που, έχοντας ως δεδομένα:
* έναν ακέραιο πίνακα Α[50, 4]
* έναν ακέραιο πίνακα Β[200]
υπολογίζει πόσες από τις τιμές του Α περιέχονται μέσα
στον Β.

Λύση

       Αλγόριθμος ΑΣΚ
       Δεδομένα // Α, Β //
       Πληθ <-- 0
       Για κ από 1 μέχρι 50
           Για λ από 1 μέχρι 4
                 απ <-- Ψευδής
                 ρ <-- 1
                 Όσο (ρ <= 200) ΚΑΙ (απ = Ψευδής) επανάλαβε
                       Αν Β[ρ] = Α[κ, λ] τότε
                            απ <-- Αληθής
                       αλλιώς
                            ρ <-- ρ+1
                       Τέλος_αν
                 Τέλος_επανάληψης
                 Αν απ = Αληθής τότε
                       Πληθ <-- Πληθ+1
                 Τέλος_αν
           Τέλος_επανάληψης
       Τέλος_επανάληψης
       Αποτελέσματα // Πληθ //
       Τέλος ΑΣΚ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου