Τρίτη, 22 Μαΐου 2012

Συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία δέχεται ως παραμέτρους:
* τον πίνακα ΟΝ[135] που περιέχει τα ονοματεπώνυμα
   των 135 μαθητών της Γ' τάξης ενός λυκείου,
* τον πίνακα Β[135, 6] που περιέχει τους βαθμούς
   (στην κλίμακα 0-100 που έγραψαν οι μαθητές
    στα 6 πανελλαδικώς εξεταζόμενα μαθήματα)
και εμφανίζει τα ονοματεπώνυμα των μαθητών και τους
βαθμούς που έγραψαν, κατά αλφαβητική σειρά των
ονοματεπωνύμων (αγνοήστε την περίπτωση της
συνωνυμίας).

Λύση


     ΔΙΑΔΙΚΑΣΙΑ ΛΙΣΤΑ(ΟΝ, Β)
     ΜΕΤΑΒΛΗΤΕΣ
          ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[135], ΤΕΜΡ
          ΑΚΕΡΑΙΕΣ: Β[135, 6], Κ, Λ, Μ, ΒΟΗΘ
     ΑΡΧΗ
          ΓΙΑ Κ ΑΠΟ 2 ΜΕΧΡΙ 135
               ΓΙΑ Λ ΑΠΟ 135 ΜΕΧΡΙ Κ ΜΕ_ΒΗΜΑ -1
                     ΑΝ ΟΝ[Λ-1] > ΟΝ[Λ] ΤΟΤΕ
                           ΒΟΗΘ <-- ΟΝ[Λ-1]
                           ΟΝ[Λ-1] <-- ΟΝ[Λ]
                           ΟΝ[Λ] <-- ΒΟΗΘ
                           ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 6
                                   ΤΕΜΡ <-- Β[Λ-1, Μ]
                                   Β[Λ-1, Μ] <-- Β[Λ, Μ]
                                   Β[Λ, Μ] <-- ΤΕΜΡ
                           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                     ΤΕΛΟΣ_ΑΝ
               ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 135
               ΓΡΑΨΕ ΟΝ[Κ]
               ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 6
                     ΓΡΑΨΕ Β[Κ, Λ]
               ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου