Πέμπτη, 3 Μαΐου 2012

Συνάρτηση+Διαδικασία

1. Γράψτε συνάρτηση η οποία δέχεται ως παράμετρο τον
    αριθμό εδρών που κέρδισε ένα κόμμα στις τελευταίες
    εκλογές και ελέγχει αν το κόμμα αυτό σχηματίζει
    αυτοδύναμη κυβέρνηση (δηλαδή έχει περισσότερες από
    150 έδρες). Η συνάρτηση να περιέχει μόνο μία εντολή
    εκχώρησης.
2. Γράψτε διαδικασία η οποία δέχεται ως παράμετρο έναν
    ακέραιο πίνακα ΕΔ[8] που περιέχει τον αριθμό των εδρών
    που κέρδισαν τα 8 κόμματα στις τελευταίες εκλογές, και
    καλώντας την προηγούμενη συνάρτηση, ελέγχει ποιο από
    αυτά μπορεί να σχηματίσει αυτοδύναμη κυβέρνηση. Αν δεν
    υπάρχει κανένα τέτοιο κόμμα εμφανίζει κατάλληλο μήνυμα.

Λύση

     ΣΥΝΑΡΤΗΣΗ  Αυτοδυν(Έδρες) : ΛΟΓΙΚΗ
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Έδρες
     ΑΡΧΗ
           Αυτοδυν <-- Έδρες > 150
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


     ΔΙΑΔΙΚΑΣΙΑ Έλεγχος(ΕΔ)
     ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: ΕΔ[8], Κ, Πληθ
     ΑΡΧΗ
            Πληθ <-- 0
            ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 8
                 ΑΝ Αυτοδυν(ΕΔ[Κ]) = ΑΛΗΘΗΣ ΤΟΤΕ
                       ΓΡΑΨΕ 'Νο :', Κ
                       Πληθ <-- Πληθ+1
                 ΤΕΛΟΣ_ΑΝ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΑΝ Πληθ = 0 ΤΟΤΕ
                 ΓΡΑΨΕ 'Κανένα κόμμα δεν μπορεί να κάνει'
                 ΓΡΑΨΕ 'αυτοδύναμη κυβέρνηση!'
            ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου