Παρασκευή, 11 Μαΐου 2012

Μέγιστο μονοδιάστατου πίνακα

Θεωρείστε τους παρακάτω πίνακες:
* ΟΝ[80], που περιέχει τα ονοματεπώνυμα 80 ανθρώπων,
* ΗΛΙΚ[80], που περιέχει τις ηλικίες τους,
* ΒΑΡ[80], που περιέχει τα βάρη τους.
Γράψτε αλγόριθμο που, με δεδομένους τους παραπάνω
πίνακες, υπολογίζει και εμφανίζει το ονοματεπώνυμο του
γηραιότερου ανθρώπου. Σε περίπτωση που δύο ή περισσότεροι
άνθρωποι έχουν την ιδιότητα αυτή, ο αλγόριθμος εμφανίζει
το ονοματεπώνυμο εκείνου που έχει το μικρότερο βάρος.
Παρατήρηση : Θεωρείστε ότι όλα τα βάρη είναι διαφορετικά
μεταξύ τους.

Λύση

    Αλγόριθμος Ασκ
    Δεδομένα // ΟΝ, ΗΛΙΚ, ΒΑΡ //
    Μεγ <-- ΗΛΙΚ[1]
    ΘΜεγ <-- 1
    Για κ από 2 μέχρι 80
         Αν (ΗΛΙΚ[κ] > Μεγ) Ή 
              (ΗΛΙΚ[κ] = Μεγ ΚΑΙ  ΒΑΡ[κ] < ΒΑΡ[ΘΜεγ]) τότε
               Μεγ <-- ΗΛΙΚ[κ]
               ΘΜεγ <-- κ
         Τέλος_αν
    Τέλος_επανάληψης
    Εμφάνισε ΟΝ[ΘΜεγ]
    Τέλος Ασκ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου