Τρίτη, 22 Μαΐου 2012

Συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παράμετρο έναν
ακέραιο πίνακα Α[12, 14] και υπολογίζει πόσα στοιχεία
του πίνακα είναι πολλαπλάσια του αθροίσματος των
συντεταγμένων τους.

Λύση


     ΣΥΝΑΡΤΗΣΗ ΠΟΣΑ(Α) : ΑΚΕΡΑΙΑ
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α[12, 14], Κ, Λ, ΠΛΗΘ
     ΑΡΧΗ
           ΠΛΗΘ <-- 0
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
                ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 14
                       ΑΝ Α[Κ, Λ] MOD (Κ+Λ) = 0 ΤΟΤΕ
                            ΠΛΗΘ <-- ΠΛΗΘ+1
                       ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΠΟΣΑ <-- ΠΛΗΘ
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου