Σάββατο, 12 Μαΐου 2012

Φιλτράρισμα

Γράψτε αλγόριθμο που :
α) διαβάζει  τις πόλεις στις οποίες κατοικούν κάποιοι
     Έλληνες πολίτες (η είσοδος δεδομένων ολοκληρώνεται
     όταν δοθεί η απάντηση 'ΝΑΙ' στην υποβαλλόμενη προς
     το χρήστη ερώτηση 'ΟΛΟΚΛΗΡΩΣΗ   ΕΙΣΟΔΟΥ ?'
     ή όταν το πλήθος των πολιτών φτάσει το 130),
β) υπολογίζει και εμφανίζει το πλήθος των διαφορετικών
    πόλεων που έχουν καταγραφεί,
γ) αν το αποτέλεσμα στο ερώτημα β) δεν υπερβαίνει το 50,
    ο αλγόριθμος εμφανίζει τις πόλεις αυτές στη μονάδα
    εξόδου.

Λύση

      Αλγόριθμος Ασκ
      Πληθ <-- 0
      Διαφ <-- 0
      Αρχή_επανάληψης
             Διάβασε Πόλη
             Πληθ <-- Πληθ+1
             Βρεθ <-- Ψευδής
             λ <-- 1
             Όσο (λ <= Διαφ) ΚΑΙ (Βρεθ = Ψευδής) επανάλαβε
                   Αν ΠΟΛΕΙΣ[λ] = Πόλη τότε
                         Βρεθ <-- Αληθής
                   αλλιώς
                         λ <-- λ+1
                   Τέλος_αν
             Τέλος_επανάληψης
             Αν Βρεθ = Ψευδής τότε
                   Διαφ <-- Διαφ+1
                   ΠΟΛΕΙΣ[Διαφ] <-- Πόλη
             Τέλος_αν
             Εμφάνισε 'ΟΛΟΚΛΗΡΩΣΗ   ΕΙΣΟΔΟΥ ?'
             Διάβασε Απ
      Μέχρις_ότου (Πληθ = 130) Ή (Απ = 'ΝΑΙ')
      Εμφάνισε Διαφ
      Αν Διαφ <= 50 τότε
             Για λ από 1 μέχρι Διαφ
                   Εμφάνισε ΠΟΛΕΙΣ[λ]
             Τέλος_επανάληψης
      Τέλος_αν
      Τέλος Ασκ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου