Σάββατο, 12 Απριλίου 2014

Απλοποίηση

Ξαναγράψτε το παρακάτω σύνολο εντολών με
απλούστερο τρόπο, έτσι ώστε όμως το νέο
σύνολο εντολών να εμφανίζει τα ίδια αποτελέσματα.
      Για Μ από 4 μέχρι 8 με_βήμα 9
            Για Ν από 5 μέχρι 2 με_βήμα -6
                Για Ξ από 12 μέχρι 25 με_βήμα 18
                     Εμφάνισε Μ+Ν+Ξ
                Τέλος_επανάληψης
            Τέλος_επανάληψης
      Τέλος_επανάληψης
      Εμφάνισε Μ+Ν+Ξ

Λύση

      Εμφάνισε 4+5+12
      Εμφάνισε 30-1+13
      

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου