Παρασκευή, 17 Ιουνίου 2011

Απλοποίηση

Απλοποιήστε το παρακάτω σύνολο εντολών
     Διάβασε α
     Αν α > 27 τότε
           β <-- Ψευδής
     αλλιώς
           β <--  Αληθής
     Τέλος_αν
     Αν β Ή ΟΧΙ(β) τότε
           γ <-- α^2
     Τέλος_αν
     γ <-- γ+1

Λύση

     Διάβασε α
     β <-- α <= 27
     γ <-- α^2+1
    

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου