Τετάρτη, 8 Ιουνίου 2011

Άσκηση : επεξεργασία στοιχείων μονοδιάστατου πίνακα

Σε μια τάξη φοιτούν 25 μαθητές. Γράψτε αλγόριθμο που,
δοθέντος του πίνακα ΥΨΗ[25] που περιέχει τα ύψη των 
μαθητών αυτής της τάξης, εμφανίζει τους αύξοντες 
αριθμούς (1-25) των 5 ψηλότερων μαθητών.
Παρατήρηση : Όλα τα ύψη είναι διαφορετικά μεταξύ τους.


Λύση

     Αλγόριθμος ΤΑΞΗ
     Δεδομένα // ΥΨΗ //
     Για κ από 1 μέχρι 25
          ΑΑ[κ] <-- κ
     Τέλος_επανάληψης
      Για κ από μέχρι 25
          Για λ από 25 μέχρι κ με_βήμα -1
               Αν ΥΨΗ[λ-1] < ΥΨΗ[λ] τότε
                     Βοηθ <-- ΥΨΗ[λ-1]
                     ΥΨΗ[λ-1] <-- ΥΨΗ[λ]
                     ΥΨΗ[λ] <-- Βοηθ
                     ΤΕΜΡ <-- ΑΑ[λ-1]
                     ΑΑ[λ-1] <-- ΑΑ[λ]
                     ΑΑ[λ] <-- ΤΕΜΡ
               Τέλος_αν
          Τέλος_επανάληψης
     Τέλος_επανάληψης
     Για κ από 1 μέχρι 5
           Εμφάνισε ΑΑ[κ]
     Τέλος_επανάληψης
     Τέλος ΤΑΞΗ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου