Πέμπτη, 29 Μαΐου 2014

Συγγραφή διαδικασίας

Γράψτε διαδικασία που εμφανίζει όλα τα στοιχεία
του ακέραιου πίνακα Α[12, 14] που είναι θετικά,
και πολλαπλάσια του 8 αλλά όχι του 24.

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΦΙΛΤΡΟ(Α)
ΜΕΤΑΒΛΗΤΕΣ
      ΑΚΕΡΑΙΕΣ: Α[12, 14], Κ, Λ
ΑΡΧΗ
      ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
          ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 14
               ΑΝ (Α[Κ, Λ] > 0) KAI (Α[Κ, Λ] MOD 8 = 0)
                      KAI (Α[Κ, Λ] MOD 24  < >  0) TOTE
                     ΓΡΑΨΕ Α[Κ, Λ]
               ΤΕΛΟΣ_ΑΝ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου