Σάββατο, 24 Μαΐου 2014

Έξοδος αποτελεσμάτων

Τι θα εμφανίσει  το παρακάτω σύνολο εντολών
   Για κ από 120 μέχρι 90 με_βήμα -40
       Για λ από 4 μέχρι 12 με_βήμα 17
            Για μ από κ+λ μέχρι 124 με_βήμα 2014
                 Εμφάνισε κ*λ+μ
            Τέλος_επανάληψης
       Τέλος_επανάληψης
   Τέλος_επανάληψης

Λύση

Η εξωτερική Για εκτελείται μόνο για κ = 120,
η εσωτερική Για εκτελείται μόνο για λ = 4
και η πιο εσωτερική Για εκτελείται μόνο για
κ+λ = 120+4 = 124. Κατά συνέπεια η
Εμφάνισε θα εκτελεστεί μόνο μια φορά
και αφού κ*λ+μ = 120*4+124 = 604, στη
μονάδα εξόδου θα εμφανιστεί: 604

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου