Πέμπτη, 29 Μαΐου 2014

Επεξεργασία παράλληλων μονοδιάστατων πινάκων

Στη Γ τάξη ενός ΓΕΛ φοιτούν 140 μαθητές. Γράψτε
αλγόριθμο που με δεδομένο τον πίνακα ΟΝ[140]
που περιέχει τα ονοματεπώνυμα των μαθητών,
τον πίνακα  ΦΥΛΟ[140] που περιέχει το φύλο
τους (Αληθής - αγόρι, Ψευδής - κορίτσι) και τον
πίνακα ΚΑΤ[140] που περιέχει τις κατευθύνσεις
τους, εμφανίζει:
α) τα ονοματεπώνυμα των αγοριών της τεχνολογικής
    κατεύθυνσης,
β) τα ονοματεπώνυμα των κοριτσιών της θετικής
    κατεύθυνσης,
γ) τα ονοματεπώνυμα των μαθητών της θεωρητικής
    κατεύθυνσης.
Θεωρείστε ότι σε κάθε κατεύθυνση φοιτά τουλάχιστον
ένα αγόρι και ένα κορίτσι.

Λύση

Αλγόριθμος ΓΕΛ
Δεδομένα // ΟΝ, ΦΥΛΟ, ΚΑΤ //
Εμφάνισε 'Ονοματεπώνυμα αγοριών τεχνολογικής'
Για κ από 1 μέχρι 140
    Αν (ΚΑΤ[κ] = 'Τεχνολογική') ΚΑΙ 
          (ΦΥΛΟ[κ] = Αληθής) τότε
          Εμφάνισε ΟΝ[κ]
    Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε 'Ονοματεπώνυμα κοριτσιών θετικής'
Για κ από μέχρι 140
    Αν (ΚΑΤ[κ] = 'Θετική') ΚΑΙ 
          (ΦΥΛΟ[κ] = Ψευδής) τότε
          Εμφάνισε ΟΝ[κ]
    Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε 'Ονοματεπώνυμα μαθητών θεωρητικής'
Για κ από μέχρι 140
    Αν ΚΑΤ[κ] = 'Θεωρητική'  τότε
          Εμφάνισε ΟΝ[κ]
    Τέλος_αν
Τέλος_επανάληψης
Τέλος ΓΕΛ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου